プラグインアップデートしたら、プラグアウトされる。

アップデート怖いわー。

WordPressについて、まだまだヒヨっ子な私。おそらく標準でインストールされている?プラグイン。なにげなく更新サインがたっていた。特に何も気にせず、アップデートを選択。すると・・・

Parse error: syntax error, unexpected …(以下、省略)

は?

真っ白な画面に殺伐したメッセージ。構文エラーってなにそれ。いやいや、さすがにテストしてから公開するだろ?ロジックエラーなら、半分諦めるけど、構文エラーって何よ?仕方ないぁ・・・

まぁ何千行もコード書いてると、こんなミスも仕方ないのかなぁー、管理画面に戻ろう!えぃ!

Parse error: syntax error, unexpected …(以下、省略)

はぁ?

プラグインアップデート失敗しただけで、管理画面すら開けなくなるとか・・・そこ分離しておけよ。WordPressってそんなシビアな設計なのか?・・・んっッ?、この瞬間、嫌な予感が脳裏をよぎる。私はおもむろにログイン画面にアクセスする。

Parse error: syntax error, unexpected …(以下、省略)

はあああぁぁぁ(#゚Д゚)!?

朝から何やってんだと思いつつ最速で調べまくって20分程度で回復に至りました。
今回に限らず、せっかく構築した環境がアップデートすることで使えなくなる。これが趣味ならば、多少は済まされるけど、仕事だったらと思うとゾッとする。

こういうことが起きるから、ソフトウェアアップデートって気軽に出来ないのだ。ね、マイクロソフトさん。